Mathematical.jp

ネットワークエンジニアへの道しるべ

ネットワーキングラボ

ネットワークエンジニアを目指す人のための初級ネットワーク技術解説サイト

ネットワークエンジニア,ccna,nat,ipaddress

 

現代社会においてその情報インフラの中心となるコンピューター通信ネットワーク。 その中心的立場の技術者であるネットワークエンジニアとは、ルータやスイッチなどを使用したLAN環境など、企業内環境などといった機関や組織においてサービスを提供する情報技術者です。

 

 

そのサービスを余すところなく提供するために、プラットフォーム環境で稼動するファイアウォールやDNS、ルータ、スイッチなどの機器を理解し、これらの連携を実現するためにネットワークケーブルや商用回線といった物理的な要素やプロトコルにも幅広く精通した存在であるといえます。

 

当サイトではわかりづらい表記や説明はなるべく避けながら、ネットワークの基本的知識ないひとでも理解できることを目的とし、ネットワークエンジニアにとって必要最低限の知識を、ビギナーにとっても馴染みやすいように習熟させ、独学でこの分野における初歩的かつ基本的な内容を可及的速やかに理解かつ習得させるためのサポートを第一の目的としています。

 

 

nextupprevious

新着情報

 

 

コンテンツ

ネットワークの基礎知識

IPaddress
IPアドレスとはインターネットやLAN内において個々の機器を識別し通信を行うために割り振られた識別番号になります。このセクションではおもに一般的に使われている32ビットのIPv4を扱い、LAN内で使われるプライベートIPアドレスやインターネットで使用されるグローバルIPアドレスの違い、さらにはIPアドレスのクラスの概念などを解説します。

 

subnet mask
サブネットマスクとはIPアドレスのネットワークアドレス部とホストアドレス部を識別するための数値になります。このサブネットマスクを使うことによって理論的にIPアドレスを細分化することができます。

 

ワイルドカードマスク
ワイルドカードマスクとはビットの進行がサブネットマスクの逆になったものになります。右から順に1ビットを増やしていきます。1がついたところは自由にビットを組み替えることができます。

 

 

ルータ基本操作演習

テラターム設定
フリーで配布されているターミナルソフトを使用して、実際にルータへのコマンド入力のための前準備になります。

 

ルータ一台を仕様した基本操作
ルータ一台での基本操作
ルータへコンソール接続してPCモニタにおいて実際にルータの基本操作を行います。簡単なコマンドを使用したマシンの緒元の確認の仕方などを解説します。

 

コンソール基本操作
ターミナルソフト上で実行するコンソールパスワードやタイムアウトの設定の仕方などを簡単に解説します。

 

ルータのセットアップモード
初期設定などを行う場合に使用されるセットアップモードについて、その見方などを学習します。

 

 

ルータ2台を使用した基本操作
ルータへのIPアドレス設定
ルータへのIPアドレスの設定の仕方や設定したインターフェイスの有効化の仕方、さらにはIPアドレスの削除の仕方や追加IPアドレスの設定のコマンドなどを学びます。

 

ルータ2台へのIPアドレス設定 2台のルータを使用し時においてシリアル接続でのインターフェイスのIPアドレスの設定など、さらにはクロックレートや帯域幅の設定・カプセル化の仕方などについて解説します。

 

CDPの操作方法
2つのルータを用いてCDPの役割や機能について学びます。

 

ホスト名の名前解決
インターフェイスのIPアドレスに対し、固有の名前をマッピングするコマンドについて学びます。

 

telnetの操作方法
インターネットやイントラネット上においてPCなどを遠隔操作するための機能の基本的なコマンド操作について解説します。

 

RIPルーティング
IPルーティングにおける代表的なプロトコル“RIP”を用いたダイナミックルーティングについて解説しています。

 

 

IPルーティング

IPルーティングとは、あるネットワークから別のネットワークまで、そのパケットを移動(送信)させるプロセスになります。このチャプターでは3つのCiscoルータを用いたIPルーティングの設定およびその確認の方法を解説します。

 

スタティックルーティング
スタティックルーティングとは、IPルーティングにおいてルーティングテーブルにないネットワーク情報を管理者が手動でルータに設定する方法になります。

 

デフォルトルーティング
デフォルトルーティングとはルーティングテーブルに存在しないリモートネットワークを宛先とするパケットをネクストホップルータに送信するためのプロセスになります。

 

RIPルーティング
RIP(Routing Information Protocol)というのはダイナミックルーティングと呼ばれるもので、このダイナミックルーティングはルーティングテーブルが更新され、ネットワーク内のすべてのルータがルーティング情報を共有します。またIPなどのルーテッドプロトコルはインターネットワーク内においてユーザデータを送ることができ、小規模から中規模のネットワーク構築において適しています。

 

 

Ciscoルータの管理

パスワード復旧
CISCO2500ルータでのパスワード復旧。 show versionでコンフィグレーションレジスタ値を確認し、リブートさせた時にブレーク信号をいれて操作していきます。

 

iOSバックアップ
CIscoIOSが万が一壊れたときの場合やアップグレードする際の前準備として、現状のファイル群をtftpと呼ばれるホストサーバーに保存する作業をしておきます。

 

linuxPCでの接続
LinuxPCからのコンフィグ操作のための接続方法。

 

 

ネットワークラボ

NAT
NATとはローカルエリアネットワーク内におけるプライベートIPアドレスをインターネットに接続する際にその内部IPアドレスをグローバルIPアドレスに変換するための技術のことを言います。

 

スタティックNAT
スタティックNATの設定はインサイド(内部)ローカルIPアドレスをインサイド(内部)グローバルIPアドレスとの「1対1」の変換によって固定的に行う設定になります。

 

ダイナミックNAT
ダイナミックNATの設定は、変換するグローバルIPアドレスの範囲(IPアドレスプール)の設定と、IPアドレス変換の対象を指定するアクセスリストの定義が必要になり、さらには内部グローバルIPアドレスを使用することを許可する送信元IPアドレスを、標準IPアクセスリストの許可文で指定します。

 

PATオーヴァーロード
PATはダイナミックNATにポート番号を付加して多重化を行い、複数のローカルIPアドレスを1つのグローバルIPアドレスにマッピングすることによってIPアドレスの効率的な利用を可能にした技術です。 ダイナミックNATと大きく異なる点はかならず「overload」を指定することになります。

 

VLAN
VLANとは、スイッチなどの機器を用いて、ネットワークの物理的な接続とは独立した形によってドメインを仮想的に分割する技術になります。この設定を行うことによりホストなどの端末機器において物理的な制限を気にすることなくネットワークのグループ化が可能になります。

 

 

このサイトに関して

当サイトは主サイトMathematical.jpのサテライトサイトになります。管理人のスペックはCCNA、CCDA(その他基本情報、医療情報技師など)になります。ちなみに私が受けた試験(CCNA)のシミュレーションはコの字とPATオーバーロードでした(機会があればコの字の解説を載せたいと思います)。

 

ページの進め方は、ページの下にあるnextボタンをクリックすればj順通りに進んでいくようになっていますが上の当ページのそれぞれのセクションボタン、またはサイトマップで目的とするページををクリックすればそれぞれのコンテンツへ進めるようになっております。

 

 

nextupprevious

このチャプターではネットワークの基礎知識について学んでいきます。


nextupprvious

コンソール接続によるテラタームを使用したルータへのIPアドレス設定、ダイナミックルーティングなどの基本的な操作方法について学んでいきます。

 

 

nextupprevious

このチャプターではルータ操作におけるIPルーティングの種類とその設定方法を学びます。
一連の操作学習はIPを使用するすべてのルータ及びコンフィグレーションに関わってきますのでよく理解する必要があります。

 

 

IPルーティングとは

IPルーティングとは、あるネットワークから別のネットワークまで、そのパケットを移動(送信)させるプロセスになります。
このチャプターでは3つのCiscoルータを用いたIPルーティングの設定およびその確認の方法を解説します。

 

 

ルータの初期設定

それぞれのルータの名前をRouterA RouterB RouterCとした以下のようなネットワーク構成を考えます。

ネットワークエンジニア,ccna,nat,ipaddress,IPルーティング

 

このような状態になるように設定していきます。

 

 

 

RouterAの設定

RouterAに接続して以下のような設定をします。
ホスト名、パスワード、バナー、インターフェイスdescription、各インターフェイスのIPアドレスのそれぞれの設定。
Router> enable
Router# config terminal
Router(config)# hostname RouterA
RouterA(config)# enable secret admini
RouterA(config)# line console 0
RouterA(config-line)# password admini
RouterA(config-line)# login
RouterA(config-line)# line aux 0
RouterA(config-line)# password admini
RouterA(config-line)# login
RouterA(config-line)# line vty 0 4
RouterA(config-line)# password admini
RouterA(config-line)# login
RouterA(config-line)# interface fastethernet 0/0
RouterA(config-if)# ip address 172.16.40.1 255.255.255.0
RouterA(config-if)# description LAN_40 Connection
RouterA(config-if)# no shutdown
RouterA(config-if)# interface serial 0/0
RouterA(config-if)# ip address 172.16.20.2 255.255.255.0
RouterA(config-if)# description Connection RouterB
RouterA(config-if)# no shutdown
RouterA(config-if)# exit
RouterA(config)# banner motd #
this is the RouterA
#
RouterA(config)# exit
RouterA# copy run start
RouterA#

 

 

RouterBの設定

RouterBに接続しホスト名、パスワード、インターフェイスdescription、バナー表示、各インターフェイスのIPアドレスのそれぞれの設定。
Router> enable
Router# config terminal
Router(config)# hostname RouterB
RouterB(config)# enable secret admini
RouterB(config)# line console 0
RouterB(config-line)# password admini
RouterB(config-line)# login
RouterB(config-line)# line aux 0
RouterB(config-line)# password admini
RouterB(config-line)# line vty 0 4
RouterB(config-line)# password admini
RouterB(config-line)# login
RouterB(config-line)# interface fastethernet 0/0
RouterB(config-if)# ip address 172.16.10.1 255.255.255.0
RouterB(config-if)# description LAN_10 Connection
RouterB(config-if)# no shutdown
RouterB(config-if)# interface serial 0/0
RouterB(config-if)# ip address 172.16.20.1 255.255.255.0
RouterB(config-if)# description Connection RouterA
RouterB(config-if)# no shutdown
RouterB(config-if)# clock rate 64000
RouterB(config-if)# interface serial 0/1
RouterB(config-if)# ip address 172.16.30.1 255.255.255.0
RouterB(config-if)# description Connection RouterC
RouterB(config-if)# clock rate 64000
RouterB(config-if)# no shutdown
RouterB(config-if)# exit
RouterB(config)# banner motd #
this is the RouterB
#
RouterB(config)# exit
RouterB# copy run start
RouterB#

 

 

 

 

RouterCの設定

RouterCに接続しホスト名、パスワード、インターフェイスdescription、バナー表示、各インターフェイスのIPアドレスのそれぞれの設定。
Router> enable
Router# config terminal
Router(config)# hostname RouterC
RouterC(config)# enable secret admini
RouterC(config)# line console 0
RouterC(config-line)# password admini
RouterC(config-line)# login
RouterC(config-line)# line aux 0
RouterC(config-line)# password admini
RouterC(config-line)# line vty 0 4
RouterC(config-line)# password admini
RouterC(config-line)# login
RouterC(config-line)# interface fastethernet 0/0
RouterC(config-if)# ip address 172.16.50.1 255.255.255.0
RouterC(config-if)# description LAN_50 Connection
RouterC(config-if)# no shutdown
RouterC(config-if)# interface serial 0/0
RouterC(config-if)# ip address 172.16.30.2 255.255.255.0
RouterC(config-if)# description Connection RouterB
RouterC(config-if)# no shutdown
RouterC(config-if)# exit
RouterC(config)# banner motd #
this is the RouterC
#
RouterC(config)# exit
RouterC# copy run start
RouterC#

 

 

コンフィグレーションの確認

3つのルータに対して行った設定を確認してみましょう。
まずルータAで次のように入力します。
RouterA# show running-config

 

 

RouterA# show ip route

 

つづいてルータB、ルータCに対しても同じように設定の確認をしてみましょう。
show running-config を行うとルータ全体の設定が表示されます。
show ip route はその対象ルータのルーティングテーブルを表示させることができます。

 

 

ルータはルータ自身に接続されているネットワークのみそのルーティングテーブルを表示させることができます。
ルーティングテーブルにないネットワークにパケット送信する場合はそのネットワークのルーティングテーブルを設定して、リモートネットワークに到達するための設定をする必要があります。

 

 

 

nextupprevious

構内LAN環境を構築・運用していくうえでIOS(Internetworking Operating SYStem)とコンフィグレーションファイルはデバイス内の別々の場所にあったりするのでそれぞれの存在する場所や機能をよく理解する必要があります。

 

nextupprevious

 

 

 

参考コマンド一覧

コマンド

説明

copy flash tftp

ファイルをフラッシュメモリからTFTPホストへコピー

copy run start

running-configからstartup-configへコピー

copy run tftp

running-configファイルをTFTPへコピー

copy tftp run

コンフィグレーションをTFTPホストからrunning-configファイルへコピー

copy tftp flash

ファイルをTFTPホストからフラッシュメモリーへコピー

cdp enable

インターフェイスごとにcdpをオンにする

cdp holdtime

cdpパケットのホールドタイム値を変更

cdp run

ルータのcdpをオンにする

cdp timer

cdpの更新タイマーの変更

disconnect

送信元ルータからリモートルータへのコネクションの切断

config-register

ルータのブート方法を指定しコンフィグレーションレジスタ値の変更

erase startup-config

NVRAMの削除

ip host

ホストテーブルの作成

show cdp

CDPタイマーとホールドタイムの表示

show cdp entry

 

show cdp neighbor

接続された隣接デバイスの詳細表示

show cdp neighbor detail

show cdp neighborによる表示に加えてIPアドレスやIOSバージョンの情報を表示

show cdp traffic

デバイスで送受信されたcdpパケットとエラー表示

show flash

フラッシュメモリファイルの表示

show hosts

ホストテーブルの表示

show run

show running-configの省略形 running-configファイルを表示

show sessions

telnet経由で接続しているデバイスセッションの表示

show start

show startup-configの省略形 startup-configファイルを表示

show version

コンフィグレーションレジスタ、IOSバージョンとそのタイプの表示

no cdp enable

CDPをオフにする

no cdp run

ルータ全体のcdpを無効にする

no ip host

ホストテーブルからのホスト名の削除

 

 

nextupprevious

内部LAN(プライベートアドレス)を外部LAN(グローバルアドレス)に変換するための技術であるNATの設定、スイッチなどの機器を用いてネットワークの物理的な接続とは独立した形によってドメインを仮想的に分割する技術であるVLANの設定などについて解説していきます。

 

 

nextupprevious


ホーム RSS購読 サイトマップ
TOP 線形代数 ベクトル解析 慣性モーメント 解析力学 微分方程式 NEへの道しるべ