ネットワークエンジニアへの道しるべ


VLANとは

VLANとは、スイッチなどの機器を用いてネットワークの物理的な接続とは独立した形によってドメインを仮想的に分割する技術になります。 ホストなどの端末機器において物理的な制限を気にすることなくネットワークのグループ化が可能になります。

VLANの種類

スタティックVLAN

スイッチのポートごとにどのVLANに所属するかを手動で設定します。

ダイナミックVLAN

それぞれの機器に割り当てられているMACアドレスごとにどのVLANに所属させるかを設定します。

スイッチにVLANを設定するメリット

ブロードキャストドメインを分割できます。
異なるVLAN間同士においてそのデータの送受信ができない。
特に2のポイントではセキュリティの向上があげられます。

 

VLANの設定

このセクションでは2つのスイッチと1つのルータを使用したVLANの設定を行ってみましょう。 名前はSwitchA、SwitchBとしてVLANコンフィグレーション用にし、ルータは名前をRouterにしてこれをVLAN間のルーティング用に使用します。
2つのスイッチにはそれぞれホスト名、IPアドレス、サブネットマスク、デフォルトゲートウェイ、さらにVTPと呼ばれるCisco独自のプロトコルを設定し、最後にルータRouterでVLAN間ルーティングを施します。

VTP(VLANトランキングプロトコル)

VTPとはCisco独自のプロトコルになります。これはVLANの設定・削除・管理などを容易にするために用いられ、次に示すような特徴があります。
VTPドメインを共有するスイッチにおいてVLAN情報の整合性を維持します。
自律的なVLAN情報の保持によりスイッチの維持管理作業を簡素化します。
VLAN情報の一括管理によりVLAN設定のミスを減少させることができます。

このVLAN情報の整合性を維持するためにVTPには次の役立つ3つのモードがあります。
VTP(レイヤ2のプロトコル)における3つのモード
 

VTPの受信

VLANの作成

VLANの削除

VLAN情報の保持

サーバモード (デフォルト設定)

クライアントモード 受信のみ
  • 受け取ったVTPアドバタイズメントを他のスイッチに転送・処理する

×

×

×

トランスペアレントモード

×

自身でVLAN作成
  • ほかのスイッチにアドバタイズしない
自身でVLANの削除
  • ほかのスイッチにアドバタイズしない
 

VLAN間ルーティングの設定

  • ルータのサブインターフェイスに対して設定
  • トランクのカプセル化タイプとVLAN番号を対応づけます
ルータとスイッチの間の回線をトランクに設定
このときルータ側では1つのインターフェイスにサブインターフェイスという仮想のインターフェイスを作成して設定を行います。
Router(config-if)#interface fastethernetポート番号・サブインターフェイス

 

サブインターフェイスを作成した後はトランクの設定を行います。
Router(config-subif)#encapsulationisl | dot1q} {VLAN ID

ポートのトランク化

複数のVLAN情報を運ぶ場合において、各フレームにどのVLAN情報が所属しているかの識別方法にトランクがあります。 これはスイッチ間でVLAN内における通信を可能にし、複数のVLANトラフィックを、トランク化したポートを通じてほかのスイッチに対して運ぶことを可能にします。主要なものに次の2つがあります。
  • ISL(Cisco独自のプロトコル)
  • IEEE802.1q

ISLとIEEE802.1q

どちらともOSI階層モデルにおけるデータリンク層で用いられるプロトコルになります。

ISL

VLANごとにスパニングツリー情報を保持します。

IEEE802.1q

イーサネットフレーム自体にタグを挿入します。標準仕様では全VLAN情報において1つのスパニング情報を保持します。
さらにポートをトランク化する場合、次のような条件があります。
ポート速度100Mbps
全二重通信

 

 

次のようなネットワーク構成図をもとに設定を進めます。
vlan

SwitchAの設定

SwitchAに接続しホスト名、IPアドレス、サブネットマスク、デフォルトゲートウェイを設定し、IPアドレスは192.168.2.100/24、デフォルトゲートウェイのIPアドレスは192.168.2.254に設定します。

さらにトランクポートの設定を行います。

Switch> enable
Switch# config terminal
Switch(config)# hostname SwitchA
SwitchA(config)# ip default-gateway 192.168.2.254
SwitchA(config)# interface vlan 1
SwitchA(config)# ip address 192.168.2.100 255.255.255.0
SwitchA(config)# interface fastethernet 0/10
SwitchA(config)# switchport mode trunk
SwitchA(config-if)# speed 100
SwitchA(config-if)# duplex full
SwitchA(config-if)# interface fastethernet 0/11
SwitchA(config-if)# switchport mode trunk
SwitchA(config-if)# speed 100
SwitchA(cofnig-if)# duplex full
SwitchA(config-if)# exit
SwitchA# show run

VTPドメインの設定
SwitchAをVTPサーバーに指定します。VTPドメインをvtpsimuとします。
SwitchA# config terminal
SwitchA(config)# vtp domain vtpsimu
SwitchA(config)# exit
SwitchA# show vtp status


SwitchBへのvlan設定

SwitchBに接続してホスト名、IPアドレス、サブネットマスク、デフォルトゲートウェイ、トランクポートの設定を行います。
IPアドレスは192.168.2.101/24、デフォルトゲートウェイIPアドレスは192.168.2.254に設定します。
設定が終わったらshow runコマンドで確認してみましょう。

Switch> enable
Switch# config terminal
Switch(config)# hostname SwitchB
SwitchB(config)# ip default-gateway 192.168.2.254
SwitchB(config)# interface vlan 1
SwitchB(config-if)# ip address 192.168.2.3 255.255.255.0
SwitchB(config-if)# interface fastethernet 0/11
SwitchB(config-if)# switchport mode trunk
SwitchB(config-if)# speed 100
SwitchB(config-if)# duplex full
SwitchB(config-if)# exit
SwitchB(config)# exit
Switch# show run

 

VTPクライアントの設定

SwitchBをVTPドメインのvlansimuのメンバーに設定し、さらにVTPクライアントとして設定します。

SwitchB# config terminal
SwitchB(config)# vtp domain vlansimu
SwitchB(config)# vtp mode client
SwitchB(config)# exit
SwitchB# show vtp status

 

SwitchAにdomain2、domain3という名前の2つのVLAN作成します。

SwitchA# vlan database
SwitchA(vlan)# vlan 2 name domain2
SwitchA(vlan)# vlan 3 name domain3
SwitchA(vlan)# exit

上の設定ではVLAN2とVLAN3という2つのVLANを作成しています。VLAN1というのはデフォルトで設定されておりすべてのSwitchに設定されています。なので削除したり変更することはできません。

 

VLAN情報の確認

SwitchBに接続してVLAN情報がVTPによって割り当てられたかの確認をしてみましょう。
次のように入力します。

SwitchB# show vlan

 

vlan2へのメンバーの割り当て

SwitchAとSwitchBに接続して、ホストAとホストBをサブネットマスクが192.168.2.0/24のdomain2 VLAN 2へ割り当てます。
fa0/1ポートをVLAN 2のメンバーに設定し、ホストAのIPアドレスを192.168.2.1にし、ホストBのIPアドレスを192.168.2.2に設定します。デフォルトゲートウェイは全部192.168.2.254になります。

 

SwitchAへのVLAN2へのメンバー設定

SwitchA# config terminal
SwitchA(config)# interface fastethernet 0/1
SwitchA(config-if)# switchport access vlan 2
SwitchA(config-if)# switchport mode access

show runコマンドで確認します。

 

SwitchBへのVLAN2へのメンバー設定

SwitchB# config terminal
SwitchB(config)# interface fastethernet 0/1
SwitchB(config-if)# switchport access vlan 2
SwitchB(config-if)# switchport mode access

show runコマンドで確認します。

 

vlan3へのメンバーの割り当て

ホストCとホストDをサブネットマスクが192.168.3.0/24のdomain3 VLAN3に割り当てる作業をします。
SwitchA、SwitchBに接続してfa0/2ポートをVLAN3のメンバーに設定し、ホストCのIPアドレスを192.168.3.1に設定、ホストDのIPアドレスを192.168.3.2に設定。さらにデフォルトゲートウェイは192.168.3.254に設定します。

 

SwitchAへのVLAN3へのメンバー設定

SwitchAに接続してfa0/2をVLAN3のメンバーに設定します。

SwitchA# config terminal
SwitchA(config)# interface fastethernet 0/2
SwitchA(config-if)# switchport access vlan 3
SwitchA(config-if)# switchport mode access

show runコマンドで確認します。

 

SwitchBへのVLAN3へのメンバー設定

SwitchBに接続してfa0/2をVLAN3のメンバーに設定します。

SwitchB# config terminal
SwitchB(config)# interface fastethernet 0/2
SwitchB(config-if)# switchport access vlan 3
SwitchB(config-if)# switchport mode access

show runコマンドで確認します。

 

vlan間のping疎通の確認

同じVLANメンバーのホストAとホストB間、および同じVLANメンバーのホストCとホストD間でpingが成功し、違うVLANメンバーのホストAからホストC、さらにはホストAからホストD間等はpingが失敗します。
そもそもホストAとホストCはネットワークIPアドレスが違うために通信できないのですが、VLAN設定を行うことによってVLAN2のホストAで送信したブロードキャストはVLAN3内には送信されません。
このようにVLANの長所の一つとしてネットワーク内のトラフィック量を減少があります。

 

RouterでのVLAN間ルーティングの設定

次にRouterでVLAN間のルーティング設定を行って異なったVLAN間でも通信ができるように設定します。

Router> enable
Router# config terminal
Router(config)# interface fastethernet 0/0
Router(config-if)# no shutdown

 

0/0のインターフェイスにはIPアドレスは設定しません。もしIPアドレスが設定されてましたらno ip addressで削除します。

 

VLAN間通信の設定

VLAN2、VLAN3ようにサブインターフェイスを設定してVLAN間通信が可能になるように設定します。

Router(config)# interface fastethernet 0/0.2
Router(config-if)# ip address 192.168.2.254 255.255.255.0
Router(config-if)# encapsulation dot1q 2
Router(config-if)# exit

0.2の2はサブインターフェイス番号になります。設定されているVLAN番号に合わせるとわかりやすいです。
またdot1qのあとにある2もVLAN番号になります。

 

Router(config)# interface fastethernet 0/0.3
Router(config-if)# ip address 192.168.3.254 255.255.255.0
Router(config-if)# encapsulation dot1q 3
Router(config-if)# exit

0.3の3はサブインターフェイス番号になります。設定されているVLAN番号に合わせるとわかりやすいでしょう。
またdot1qのあとにある3もその設定されているVLAN番号になります。

 

 

この以上の設定が終わりましたら異なるVLAN間でもpingによる疎通確認が成功するのと確かめてみましょう。

VLAN,設定,IPアドレス,トランクポート,vtpドメイン,ルータ,スイッチ,ネットワーク

 

nextupprevious

VLAN関連ページ

NAT
NATとはローカルエリアネットワーク内におけるプライベートIPアドレスをインターネットに接続する際に、その内部アドレスをグローバルIPアドレスに変換するための技術のことを言います。このチャプターではNATの概念と、それらに付随する設定のスタティックNAT、ダイナミックNAT,NAPTなどについて解説します。

TOP ネットワーク基礎 テラターム設定 ルータ1台の設定 ルータ2台の設定 ルータ管理 IPルーティング ネットワークラボ