ルータ2台を使用した基本操作


IPアドレスの設定



ccna,ccnp,シスコ,ネットワークエンジニア

2台のルータを使用してIPアドレスの設定などを行ってみましょう。

RouterAにRouterAというホスト名を名づけ、E0インターフェイスにIPアドレスを設定してインターフェイスを有効化してみましょう。

この設定では設定するインターフェースが“ethernet 0”となっていますが、ルーターの機種によって名前が違いますのでその際にはshow run コマンドを使って各インターフェース名を確認してください。

RouterA# config terminal
Router(config)# hostname RouterA
RouterA(config)# interface ethernet 0
RouterA(config-if)# ip address 192.168.1.100 255.255.255.0
RouterA(config-if)# no shutdown
RouterA(config-if)# end
RouterA#

この後show interface ethrenet 0を実行して、

Ethernet0 is up, line protocol is up

となっていることを確認してみましょう。
またshow running-config を行い、E0インターフェイスのIPアドレスが

192.168.1.100 255.255.255.0

になっているかどうかを確認します。

さらにpingを飛ばしてみましょう。
テラタームまたはDOSプロンプト上で

ping 192.168.1.100

と打ち込んで成功することを確認してみましょう。

IPアドレスの上書

RouterAのE0インターフェイスに違うIPアドレス172.16.1.1/16のIPアドレスを設定してみましょう。

RouterA# config terminal
RouterA(config)# interface e 0
RouterA(config-if)# ip address 172.16.1.1 255.255.0.0
RouterA(config-if)# end
RouterA#

 

show running-configを実行してE0インターフェイスのIPアドレスが192.168.1.100 255.255.255.0 から 172.16.1.1 255.255.0.0に代わっていることを確かめてみましょう。

 

設定したIPアドレスの削除とインターフェイスの無効化

RouterAのE0インターフェイスに設定したIPアドレスを削除し、E0インターフェイスを無効化してみましょう。

RouterA# config terminal
RouterA(config)# interface e 0
RouterA(config-if)# no ip address
RouterA(config-if)# end
RouterA#

E0インターフェイスにIPアドレスが設定されてなく、さらにはインターフェイスがシャットダウンしていることを確かめましょう(E0インターフェイスに設定してあるIPアドレスは1つだけなのでno ip addressのみで大丈夫)。

 

インターフェイスのIPアドレス設定とインターフェイスの有効化

RouterAのE0インターフェイスにIPアドレス192.168.1.1/24を設定してインターフェイスを有効化してみましょう。

RouterA# config terminal
RouterA(config)# interface e 0
RouterA(config-if)# ip address 192.168.1.1 255.255.255.0
RouterA(config-if)# no shutdown
RouterA(config-if)# end
RouterA#

E0インターフェイスにIPアドレス192.168.1.1 255.255.255.0が設定され、シャットされていないことをshow running-configで確かめてみましょう。

 

追加IPアドレスの設定

RouterAのE0インターフェイスに追加のIPアドレスとして192.168.1.2/24を設定してみましょう。

RouterA# config terminal
RouterA(config)# interface e 0
RouterA(config-if)#ip address 192.168.1.2 255.255.255.0 secondary
RouterA(config-if)# end
RouterA#

show running-configでE0インターフェイスのIPアドレスに192.168.1.2 255.255.255.0が追加されていることを確認してみましょう。
追加のIPアドレスを設定したいときは“secondary”を書き足します。

 

追加IPアドレスの削除の仕方

先ほど追加したIPアドレスの削除の仕方

RouterA# config terminal
RouterA(config)# interface e 0
RouterA(config-if)# no ip address 192.168.1.2 255.255.255.0 secondary
RouterA(config-if)# end
RouterA#

show running-configでE0インターフェイスのIPアドレスから192.168.1.2 255.255.255.0のIPアドレスが消去されていることを確認してみましょう。

 

S0インターフェイスのDTE,DCE確認の仕方

次のように入力します。

RouterA# show controllers s 0

ページ上部に描かれているネットワーク構成図の通りであるならば、RouterAのS0インターフェイス表示は「DTE cable」と表示されます。



ccna,ccnp,シスコ,ネットワークエンジニア


nextupprevious

ルータへのIPアドレスの設定関連ページ

2台のルータによる基本操作
CDPの使用方法
ホスト名の名前解決
Telnetの操作方法
telnetとはグローバルまたはプライベート環境のTCP/IPにおいてホストコンピュータを遠隔操作するための標準的プロトコルになります。
ダイナミックRIP
IPルーティングの知識においてパケットの中継を行うためのルーティングの分野は避けては通れません。その主な手法はスタティックとダイナミックの2種類があげられ後者のダイナミックにおいて代表的なものにRIPがあります。これはルータが経路情報を自動的に更新するプロトコルになります。

TOP ネットワーク基礎 テラターム設定 ルータ1台の設定 ルータ2台の設定 ルータ管理 IPルーティング ネットワークラボ