ネットワークエンジニアへの道しるべ


RIPを使用したダイナミックルーティングの学習

 

 

ネットワークエンジニア,rip,ルーティング,IPアドレス,ダイナミックルーティング

IPネットワーキングにおける“ルーティング”の役割

ネットワークスキルにおけるパケット中継を行うルーティングの知識は何より不可欠になります。ネットワークエンジニアとしての分野のスキルや知識を高めるためにはこの分野の理解は外せない重要なポイントになります。

RIPの設定

次のようなネットワーク構成の想定をもとにRouterAとRouterBにRIPを設定し、疎通確認をしてみましょう。

ダイナミックRIP

RouterAのE0インターフェイスとS0インターフェイスにIPアドレスを設定してインターフェイスを有効化します。

Router# config terminal
Router(config)# hostname RouterA
RouterA(config)# interface e 0
RouterA(config-if)# ip address 192.168.1.1 255.255.255.0
RouterA(config-if)# no shutdown
RouterA(config-if)# interface s 0
RouterA(config-if)# ip address 192.168.2.1 255.255.255.0
RouterA(config-if)# no shutdown
RouterA(config-if)# end
RouterA#

show interface e0 および show interface s 0を行い、それぞれにおいて、

Ethernat0 is up, line protocol is up

Serial0 is down, line protocol is down

となっていることを確認してみましょう。
次にRouterBのE0、S0のインターフェイスにIPアドレスを設定してインターフェイスを有効化し、さらにS0インターフェイスに64000bpsのクロックレートを設定します。

Router# config terminal
Router(config)# hostname RouterB
RouterB(config)# interface e 0
RouterB(config-if)# ip address 192.168.3.1 255.255.255.0
RouterB(config-if)# no shutdown
RouterB(config-if)# interface s 0
RouterB(config-if)# ip address 192.168.2.2 255.255.255.0
RouterB(config-if)# no shutdown
RouterB(config-if)# clock rate 64000
RouterB(config-if)# end
RouterB#

RouterAのときと同じようにshow interface e0及びshow interface s 0を実行してそれぞれが

Ethernet0 is up, line protocol is up

Serial0 is up, line protocol is up

となっていることを確認してみましょう。
つぎにpingの疎通確認をすると、RouterAからRouterBのS0インターフェイスへのpingは成功しますがE0インターフェイス(192.168.3.1)へのpingは失敗します。
原因はRouterAにおいて192.168.3.0/24のネットワーク宛のルートがRouterAのルーティングテーブル上に存在しないからです。

RouterA# show ip route

 

Geteway of last resort is not set

 

C 192.168.1.0/24 is directly connected, Ethernet0
C 192.168.2.0/24 is directly connected, Serial0

なのでここからRIPの設定をします。

RouterAへのRIPの設定

RouterA# config terminal
RouterA(config)# router rip
RouterA(config-router)# network 192.168.1.0
RouterA(config-router)# network 192.168.2.0
RouterA(config-router)# end
RouterA#

 

RouterBへのRIPの設定

RouterB# config terminal
RouterB(config)# router rip
Router(config-router)# network 192.168.2.0
Router(config-router)# network 192.168.3.0
Router(config-router)# end
RouterB#

 

RouterAおよびRouterBのそれぞれのルーティングテーブルが正しく設定されているかどうかを確認します。

RouterA# show ip route

 

Gateway of last resort is not set

 

C 192.168.1.0/24 is directly connected, Ethernet0
C 192.168.2.0/24 is directly connected, Serial0
R 192.168.3.0/24 [120/1] via 192.168.2.2, 00:00:10, Serial0

 

RouterB# show ip route

 

Gateway of last resort is not set

 

R 192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:15 , Serial0
C 192.168.2.0/24 is directly connected, Serial0
C 192.168.3.0/24 is directly connected, Ethernet0

これでRIPの設定が完了したのでそれぞれのルータからpingによる疎通できるかどうかを確認してみましょう。
以下のように入力してpingによる疎通確認をしてみましょう。

RouterAからRouterBのE0インターフェイスのIPアドレスへのping送信

RouterA# ping 192.168.3.1

RouterBからRouterAのE0インターフェイスのIPアドレスへのping送信

RouterB# ping 192.168.1.1

 

vlan


nextupprevious

RIPによるダイナミックルーティング関連ページ

ルータへのIPアドレスの設定
2台のルータによる基本操作
CDPの使用方法
ホスト名の名前解決
Telnetの操作方法
telnetとはグローバルまたはプライベート環境のTCP/IPにおいてホストコンピュータを遠隔操作するための標準的プロトコルになります。

TOP ネットワーク基礎 テラターム設定 ルータ1台の設定 ルータ2台の設定 ルータ管理 IPルーティング ネットワークラボ