ネットワークエンジニアへの道しるべ


もう1台のルータを使用したs0インターフェイスの基本設定

ルータ,基本操作,ネットワークエンジニア

RouterAとRouterBで操作

これからは2つのルータを使用した設定にはいります。

 

もう一方のルータにつながれているCOMポートを選択して設定画面を表示させましょう。

 

2台目のルータへのホスト名と、E0インターフェイスのIPアドレス192.168.3.1 255.255.255.0の設定及びインターフェイスの有効化
Router# config terminal
Router(config)# hostname RouterB
RouterB(config)# interface e 0
RouterB(config-if)# ip address 192.168.3.1 255.255.255.0
RouterB(config-if)# no shut
RouterB(config-if)# end
RouterB#
show interface e 0を行って
Ethernet0 is up, line protocol is up
となっていることを確かめてみましょう。

 

RouterBのs0インターフェイスのDCEかDTEかの確認

ルータ,基本操作,ネットワークエンジニア


RouterBにおいて先ほどのセクションと同じように次の入力します。
RouterB# show controllers s 0
最初に示したネットワーク構成図の通りであれば「〜DCE cable」と表示されます。
RouterBのs0インターフェイスはDCEになります。

RouterBのS0インターフェイスへのIPアドレスの設定とインターフェイスの有効化
RouterBのS0インターフェイスにIPアドレス192.168.2.2 255.255.255.0の設定とそのインターフェイスの有効化をします。
RouterB# config terminal
RouterB(config)# interface s 0
RouterB(config-if)# ip address 192.168.2.2 255.255.255.0
RouterB(config-if)# no shut
RouterB(config-if)# end
RouterB#
show interface s0を行って
Serial0 is up, line protocol is down
となっていることを確認します。
対抗ルータのRouterAのS0インターフェイスはアップしているので物理層はupしていますがまだクロックレートは設定してませんのでデータリンク層のほうはダウンしたままの状態になっています。
クロックレートと帯域幅の設定
今度はRouterBのS0インターフェイスに64Kbpsのクロック速度と64Kbpsの帯域幅の設定をします。
次のように入力します。
RouterB# config termianl
RouterB(config)# interface s 0
RouterB(config-if)# clock rate 64000
RouterB(config-if)# bandwidth 64
RouterB(config-if)# end
RouterB#
show interface s 0を入力して
Serial0 is up, line protocol is up
となっていることを確認したのちデータリンク層がUPしたことを確認してみましょう。クロックレートを設定することによって可能になります。
またRouterAでもshow interface s 0を行って同じくUPしていることを確認してみましょう。
S0インターフェイスのカプセル化タイプの確認
次のように入力して「Encapsulation HDLC」になっていることを確認してみましょう。
RouterA# show interface s 0
RouterB# show interface s 0
使用しているルータがCiscoの場合、同期シリアルインターフェイスのデフォルトのカプセル化タイプはHDLCになります。

カプセル化タイプのPPPへの変更
RouterB# config terminal
RouterB(config)# interface s 0
RouterB(config-if)# encapsulation ppp
RouterB(config-if)# end
RouterB#
RouterAのS0インターフェイスのカプセル化はHDLCのままなのでRouterAとRouterBのカプセル化は異なるのでデータリンク層がアップしないことになります。

つまりshow interface s 0コマンドを実行した場合、カプセル化は
Encapsulation PPP
となっていますが、一方で
Serial0 is up, line protocol is down
となります。
ここでRouterBのS0インターフェイスのカプセル化をPPPからHDCLに戻してみましょう。
RouterB# config terminal
RouterB(config)#interface s 0
RouterB(config-if)# encapsulation hdlc
RouterB(config-if)# end
show interface s 0を実行して

「Encapsulation HCLC」と「Serial0 is up, line protocol is up」

となっていることを確認してみましょう。

 

最後にRouterAとRouterBの設定情報を保存せずにし、以下のようにreloadさせないようにします。
RouterA# reload
System configuration has been modified. Save?[yes/no]: no
Proceed with reload? [confirm] (Enterキー)
RouterB# reload
System configuration has been modified. Save?[yes/no]: no
Proceed with reload? [confirm] (Enterキー)

 

nextupprevious

2台のルータによる基本操作関連ページ

ルータへのIPアドレスの設定
CDPの使用方法
ホスト名の名前解決
Telnetの操作方法
telnetとはグローバルまたはプライベート環境のTCP/IPにおいてホストコンピュータを遠隔操作するための標準的プロトコルになります。
ダイナミックRIP
IPルーティングの知識においてパケットの中継を行うためのルーティングの分野は避けては通れません。その主な手法はスタティックとダイナミックの2種類があげられ後者のダイナミックにおいて代表的なものにRIPがあります。これはルータが経路情報を自動的に更新するプロトコルになります。

TOP ネットワーク基礎 テラターム設定 ルータ1台の設定 ルータ2台の設定 ルータ管理 IPルーティング ネットワークラボ